CVE-2024-21683

HIGH
8.8
CVSS Score
Published: May 21, 2024 at 11:00 PM UTC
Updated: June 17, 2026 at 07:09 AM UTC
7 products affected across 1 vendorJira ServerJira Data CenterCrucible

Using Confluence Data Center by Atlassian?

Get instant alerts when new vulnerabilities affect Confluence Data Center - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 88%
SSVC
PoC

Description

This High severity RCE (Remote Code Execution) vulnerability was introduced in version 5.2 of Confluence Data Center and Server. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 7.2, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires no user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version. If you are unable to do so, upgrade your instance to one of the specified supported fixed versions. See the release notes https://confluence.atlassian.com/doc/confluence-release-notes-327.html You can download the latest version of Confluence Data Center and Server from the download center https://www.atlassian.com/software/confluence/download-archives. This vulnerability was found internally.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

7.19.0 ≤ v ≤ 7.19.217.19.0 ≤ v ≤ 7.19217.19.0 ≤ v < 7.19.247.20.0 ≤ v ≤ 7.20.38.0.0 ≤ v ≤ 8.0.48.1.0 ≤ v ≤ 8.1.48.2.0 ≤ v ≤ 8.2.38.3.0 ≤ v ≤ 8.3.48.4.0 ≤ v ≤ 8.4.58.5.0 ≤ v ≤ 8.5.88.5.0 ≤ v < 8.5.118.6.0 ≤ v ≤ 8.6.28.7.1 ≤ v ≤ 8.7.28.8.0 ≤ v ≤ 8.8.18.9.0 ≤ v < 8.9.37.19.07.19.227.20.08.0.08.1.08.2.08.3.08.4.08.5.08.5.98.6.08.7.18.7.28.8.08.8.18.9.08.9.1
Vendor states this is fixed in 7.19.22 to 7.19.23 (unaffected)
Affected range stops below 7.19.24, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.5.11, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 8.5.9 to 8.5.10 (unaffected)
Vendor states this is fixed in 8.9.1 to 8.9.2 (unaffected)
Affected range stops below 8.9.3, so it looks safe — our inference, not a vendor statement
7.19.0 ≤ v < 7.19.247.20.0 ≤ v ≤ 7.20.38.0.0 ≤ v ≤ 8.0.48.1.0 ≤ v ≤ 8.1.48.2.0 ≤ v ≤ 8.2.38.3.0 ≤ v ≤ 8.3.48.4.0 ≤ v ≤ 8.4.58.5.0 ≤ v < 8.5.118.6.0 ≤ v ≤ 8.6.28.9.0 ≤ v ≤ 8.9.28.7.18.7.28.8.08.8.1
Affected range stops below 7.19.24, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.5.11, so it looks safe — our inference, not a vendor statement
95%
4.8.0 ≤ v < 4.8.15
Affected range stops below 4.8.15, so it looks safe — our inference, not a vendor statement
Fisheye· Atlassianatlassian-app
95%
4.8.0 ≤ v < 4.8.15
Affected range stops below 4.8.15, so it looks safe — our inference, not a vendor statement
9.12.0 ≤ v < 9.12.89.4.0 ≤ v < 9.4.21
Affected range stops below 9.12.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.4.21, so it looks safe — our inference, not a vendor statement
95%
9.12.0 ≤ v < 9.12.89.4.0 ≤ v < 9.4.21
Affected range stops below 9.12.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.4.21, so it looks safe — our inference, not a vendor statement
5.12.0 ≤ v < 5.12.85.15.2 ≤ v < 5.16.05.4.0 ≤ v < 5.4.215.15.2
Affected range stops below 5.12.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.16.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.21, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
NVD-CWE-noinfoCWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card