CVE-2024-1538

File Manager <= 7.2.4 - Cross-Site Request Forgery to Local JS File Inclusion

HIGH
8.8
CVSS Score
Published: March 21, 2024 at 03:32 AM UTC
Updated: June 17, 2026 at 07:04 AM UTC
2 products affected across 2 vendorsFile ManagerFile Manager

Using File Manager by mndpsingh287?

Get instant alerts when new vulnerabilities affect File Manager - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 11%
SSVC
No known exploit

Description

The File Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 7.2.4. This is due to missing or incorrect nonce validation on the wp_file_manager page that includes files through the 'lang' parameter. This makes it possible for unauthenticated attackers to include local JavaScript files that can be leveraged to achieve RCE via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This issue was partially patched in version 7.2.4, and fully patched in 7.2.5.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 7.2.5
Affected range stops below 7.2.5, so it looks safe — our inference, not a vendor statement
60%
v ≤ 7.2.4

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHWordfence
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-352

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card