CVE-2024-14045

OpenBoxes Product Supplier Edit Controller RoleInterceptor.groovy improper authorization

MEDIUM
6.3
CVSS Score
Published: August 18, 2026 at 08:45 AM UTC
Updated: October 1, 2026 at 11:10 PM UTC
1 product affected across 1 vendorOpenBoxes

Using OpenBoxes by N/A?

Get instant alerts when new vulnerabilities affect OpenBoxes - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.3
Exploit prediction
EPSS 0.4%
SSVC
PoC

Description

A weakness has been identified in OpenBoxes up to 0.9.2. This vulnerability affects unknown code of the file grails-app/controllers/org/pih/warehouse/RoleInterceptor.groovy of the component Product Supplier Edit Controller. Executing a manipulation can lead to improper authorization. The attack may be performed from remote. The exploit has been made available to the public and could be used for attacks. Upgrading to version 0.9.3 is able to resolve this issue. This patch is called f767ac1a5987d4865d9f158c6a967680f8e45468. It is suggested to upgrade the affected component.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 0.9.3 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (9)

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.3MEDIUMVulDB
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-285CWE-266

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card