CVE-2024-12678

Nomad Allocations Vulnerable To Privilege Escalation Within A Namespace Using Unredacted Workload Identity Tokens

MEDIUM
6.5
CVSS Score
Published: December 20, 2024 at 01:49 AM UTC
Updated: June 17, 2026 at 07:00 AM UTC
1 product affected across 1 vendorNomad

Using Nomad by HashiCorp?

Get instant alerts when new vulnerabilities affect Nomad - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Nomad Community and Nomad Enterprise ("Nomad") allocations are vulnerable to privilege escalation within a namespace through unredacted workload identity tokens. This vulnerability, identified as CVE-2024-12678, is fixed in Nomad Community Edition 1.9.4 and Nomad Enterprise 1.9.4, 1.8.8, and 1.7.16.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.4.0 ≤ v < 1.7.161.4.0 ≤ v < 1.9.41.8.0 ≤ v < 1.8.81.9.0 ≤ v < 1.9.41.4.0
Affected range stops below 1.9.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMHashiCorp
Vector?

Quick Info

StatusANALYZED
CWE
CWE-266

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card