CVE-2024-1248

Role Overwriting via Silent JIT Provisioning in Multiple WSO2 Products Enables Privilege Escalation

MEDIUM
5.3
CVSS Score
Published: July 4, 2026 at 08:38 PM UTC
Updated: July 9, 2026 at 07:01 PM UTC
5 products affected across 1 vendorAPI ManagerIdentity ServerIdentity Server As Key Manager

Using WSO2 API Manager by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 API Manager - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

The silent Just-In-Time (JIT) provisioning feature in federated authentication implementations fails to properly segregate user roles during account creation when a federated user shares a username with a local user. This allows the provisioning process to overwrite existing roles of local users with roles assigned to the federated user. Exploitation requires a federated identity provider (IDP) with silent JIT provisioning enabled and an attacker's knowledge of a local user's username. When these conditions are met, a malicious individual can leverage the JIT provisioning process to modify the roles of local users. The overwritten roles are limited to those defined within the federated IDP, typically granting minimal access rights unless explicitly configured otherwise by the federated IDP administrator.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.0.0 ≤ v < 3.0.0.1533.1.0 ≤ v < 3.1.0.2673.2.0 ≤ v < 3.2.0.3514.0.0 ≤ v < 4.0.0.2694.1.0 ≤ v < 4.1.0.1693.0.03.1.03.2.04.0.04.1.0
Affected range stops below 3.0.0.153, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.0.267, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.351, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.269, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.169, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.0.0 (unknown)
5.10.0 ≤ v < 5.10.0.2845.11.0 ≤ v < 5.11.0.3215.8.0 ≤ v < 5.8.0.1015.9.0 ≤ v < 5.9.0.1385.10.05.11.05.8.05.9.0
Affected range stops below 5.10.0.284, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.11.0.321, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.8.0.101, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.9.0.138, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.8.0 (unknown)
5.10.0 ≤ v < 5.10.0.2805.9.0 ≤ v < 5.9.0.1485.10.05.9.0
Affected range stops below 5.10.0.280, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.9.0.148, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.9.0 (unknown)
2.0.0 ≤ v < 2.0.0.3132.0.0
Affected range stops below 2.0.0.313, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
2.0.0 ≤ v < 2.0.0.3332.0.0
Affected range stops below 2.0.0.333, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-298

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card