CVE-2024-12243

Gnutls: gnutls impacted by inefficient der decoding in libtasn1 leading to remote dos

MEDIUM
5.3
CVSS Score
Published: February 10, 2025 at 03:28 PM UTC
Updated: October 22, 2026 at 10:17 PM UTC
16 products affected across 2 vendorsEnterprise LinuxOpenShift Container PlatformSIMATIC S7-1500 CPU 1518-4 Pn /dp MFP Firmware

Using N/A by N/A?

Get instant alerts when new vulnerabilities affect N/A - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

A flaw was found in GnuTLS, which relies on libtasn1 for ASN.1 data processing. Due to an inefficient algorithm in libtasn1, decoding certain DER-encoded certificate data can take excessive time, leading to increased resource consumption. This flaw allows a remote attacker to send a specially crafted certificate, causing GnuTLS to become unresponsive or slow, resulting in a denial-of-service condition.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

All versions10
Vendor states this is fixed in 0:3.6.16-8.el8_10.3 (unaffected)
Vendor states this is fixed in 0:3.7.6-21.el9_2.4 (unaffected)
Vendor states this is fixed in 0:3.8.3-4.el9_4.2 (unaffected)
Vendor states this is fixed in 0:3.8.3-6.el9 (unaffected)
Vendor states this is fixed in 6 (unknown)
Vendor states this is fixed in 7 (unknown)
v < V2.17.0
Affected range stops below V2.17.0, so it looks safe — our inference, not a vendor statement
v < V2.17.0
Affected range stops below V2.17.0, so it looks safe — our inference, not a vendor statement
v < V2.17.0
Affected range stops below V2.17.0, so it looks safe — our inference, not a vendor statement
v < V2.17.0
Affected range stops below V2.17.0, so it looks safe — our inference, not a vendor statement
v < V2.17.0
Affected range stops below V2.17.0, so it looks safe — our inference, not a vendor statement
v < V2.17.0
Affected range stops below V2.17.0, so it looks safe — our inference, not a vendor statement
v < V2.17.0
Affected range stops below V2.17.0, so it looks safe — our inference, not a vendor statement
v < V2.17.0
Affected range stops below V2.17.0, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.3MEDIUMredhat
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
LOW
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-407

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card