CVE-2024-1189

AMPPS Encryption Passphrase denial of service

HIGH
7.5
CVSS Score
Published: February 2, 2024 at 06:31 PM UTC
Updated: June 17, 2026 at 07:03 AM UTC
1 product affected across 1 vendorAmpps

Using AMPPS by N/A?

Get instant alerts when new vulnerabilities affect AMPPS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.7%
SSVC
PoC

Description

A vulnerability has been found in AMPPS 2.7 and classified as problematic. Affected by this vulnerability is an unknown functionality of the component Encryption Passphrase Handler. The manipulation leads to denial of service. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.0 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-252679. NOTE: The vendor explains that AMPPS 4.0 is a complete overhaul and the code was re-written.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.02.7
Affected range stops below 4.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

References (3)

SignaturePermissions RequiredThird Party Advisory
https://vuldb.com/?ctiid.252679
VDB EntryPermissions RequiredThird Party Advisory
https://vuldb.com/?id.252679

SSVC — Action Prioritization

SSVCPoCAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-404

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card