CVE-2024-10975

Nomad Vulnerable To Cross-Namespace Volume Creation Abusing CSI Write Permission

HIGH
7.7
CVSS Score
Published: November 7, 2024 at 09:04 PM UTC
Updated: June 17, 2026 at 06:56 AM UTC
1 product affected across 1 vendorNomad

Using Nomad by HashiCorp?

Get instant alerts when new vulnerabilities affect Nomad - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.7
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.3.0 ≤ v < 1.7.151.3.0 ≤ v < 1.9.21.8.0 ≤ v < 1.8.71.9.0 ≤ v < 1.9.21.3.0
Affected range stops below 1.9.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.7HIGHHashiCorp
Vector?

Quick Info

StatusANALYZED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card