CVE-2024-10909

Pojo Forms <= 1.4.7 - Authenticated (Subscriber+) Arbitrary Shortcode Execution via form_preview_shortcode

MEDIUM
6.3
CVSS Score
Published: December 6, 2024 at 09:22 AM UTC
Updated: June 17, 2026 at 06:56 AM UTC
1 product affected across 1 vendorPojo Forms

Using Pojo Forms by kingyes?

Get instant alerts when new vulnerabilities affect Pojo Forms - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.3
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

The The Pojo Forms plugin for WordPress is vulnerable to arbitrary shortcode execution via form_preview_shortcode AJAX action in all versions up to, and including, 1.4.7. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary shortcodes. This was partially fixed in version 1.4.8.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Pojo Forms· Kingyeswordpress-plugin
60%
v ≤ 1.4.7

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.3MEDIUMWordfence
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card