CVE-2024-10326

RomethemeKit For Elementor <= 1.5.3 - Missing Authorization in save_options and reset_widgets

MEDIUM
4.3
CVSS Score
Published: March 8, 2025 at 12:21 PM UTC
Updated: June 17, 2026 at 06:55 AM UTC
1 product affected across 1 vendorRomethemeKit For Elementor

Using RomethemeKit For Elementor by rometheme?

Get instant alerts when new vulnerabilities affect RomethemeKit For Elementor - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

The RomethemeKit For Elementor plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_options and reset_widgets functions in all versions up to, and including, 1.5.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify plugin settings or reset plugin widgets to their default state (all enabled). NOTE: This vulnerability was partially fixed in version 1.5.3.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 1.5.3v < 1.5.4
Affected range stops below 1.5.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.3MEDIUMWordfence
Vector?

Quick Info

StatusANALYZED
CWE
CWE-862

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card