CVE-2024-10302

Improper Input Validation via Signup Process in Multiple WSO2 Products Enables Content Manipulation and Data Exposure

MEDIUM
5.8
CVSS Score
Published: August 6, 2026 at 07:33 AM UTC
Updated: August 9, 2026 at 02:40 PM UTC
8 products affected across 1 vendorAPI ManagerIdentity ServerIdentity Server As Key Manager

Using WSO2 API Control Plane by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 API Control Plane - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.8
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

The user self-signup flow in multiple WSO2 products fails to adequately validate user-supplied input. This weakness allows arbitrary unvalidated data to be included within user claims, which are then used by downstream processes. Allowing unvalidated input into user claims can lead to various security risks. Malicious or malformed data injected during signup could be processed by other parts of the application, potentially enabling attacks such as content manipulation, redirection, user interface inconsistencies, unauthorized actions, and data exposure. The actual impact depends on how the compromised data is consumed and the privileges associated with the affected users.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.5.0 ≤ v < 4.5.0.104.5.0
Affected range stops below 4.5.0.10, so it looks safe — our inference, not a vendor statement
3.1.0 ≤ v < 3.1.0.3313.2.0 ≤ v < 3.2.0.4273.2.1 ≤ v < 3.2.1.394.0.0 ≤ v < 4.0.0.3184.1.0 ≤ v < 4.1.0.2004.2.0 ≤ v < 4.2.0.1384.3.0 ≤ v < 4.3.0.514.5.0 ≤ v < 4.5.0.93.1.03.2.03.2.14.0.04.1.04.2.04.3.04.5.0
Affected range stops below 3.1.0.331, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.427, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.39, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.318, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.200, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.138, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.51, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.9, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.1.0 (unknown)
5.10.0 ≤ v < 5.10.0.3585.11.0 ≤ v < 5.11.0.3795.10.05.11.0
Affected range stops below 5.10.0.358, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.11.0.379, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
5.10.0 ≤ v < 5.10.0.3515.10.0
Affected range stops below 5.10.0.351, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
2.0.0 ≤ v < 2.0.0.4002.0.0
Affected range stops below 2.0.0.400, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
4.5.0 ≤ v < 4.5.0.94.5.0
Affected range stops below 4.5.0.9, so it looks safe — our inference, not a vendor statement
4.5.0 ≤ v < 4.5.0.94.5.0
Affected range stops below 4.5.0.9, so it looks safe — our inference, not a vendor statement
1.4.1 ≤ v < 1.4.1.721.4.100 ≤ v < 1.4.100.81.4.102 ≤ v < 1.4.102.21.4.72 ≤ v < 1.4.72.681.7.2 ≤ v < 1.7.2.41.8.107 ≤ v < 1.8.107.21.8.108 ≤ v < 1.8.108.41.4.11.4.1001.4.1021.4.721.7.21.8.1071.8.108
Affected range stops below 1.4.1.72, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.4.100.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.4.102.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.4.72.68, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.6.380 (unaffected)
Affected range stops below 1.7.2.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.8.107.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.8.108.4, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.8.109 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
CHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusUNDERGOING ANALYSIS
CWE
CWE-20

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card