CVE-2024-10002

Rover IDX <= 3.0.0.2905 - Authenticated (Subscriber+) Authentication Bypass to Administrator

HIGH
8.8
CVSS Score
Published: October 22, 2024 at 04:31 AM UTC
Updated: June 17, 2026 at 06:54 AM UTC
2 products affected across 2 vendorsRoveridxRover IDX

Using Rover IDX by stevemullen?

Get instant alerts when new vulnerabilities affect Rover IDX - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

The Rover IDX plugin for WordPress is vulnerable to Authentication Bypass in versions up to, and including, 3.0.0.2905. This is due to insufficient validation and capability check on the 'rover_idx_refresh_social_callback' function. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to log in to administrator. The vulnerability is partially patched in version 3.0.0.2905 and fully patched in version 3.0.0.2906.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Roveridx· Roveridxwordpress-plugin
95%
v ≤ 3.0.0.2905v < 3.0.0.2906
Affected range stops below 3.0.0.2906, so it looks safe — our inference, not a vendor statement
Rover IDX· Stevemullenwordpress-plugin
60%
v ≤ 3.0.0.2905

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHWordfence
Vector?

Quick Info

StatusANALYZED
CWE
CWE-288CWE-306

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card