CVE-2023-6931

Out-of-bounds write in Linux kernel's Performance Events system component

HIGH
7
CVSS Score
Published: December 19, 2023 at 02:09 PM UTC
Updated: October 14, 2026 at 11:17 PM UTC
6 products affected across 3 vendorsLinux KernelDebian LinuxSIMATIC S7-1500 CPU 1518-4 Pn /dp MFP Firmware

Using Kernel by Linux?

Get instant alerts when new vulnerabilities affect Kernel - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7
Exploit prediction
EPSS 0.7%

Description

A heap out-of-bounds write vulnerability in the Linux kernel's Performance Events system component can be exploited to achieve local privilege escalation. A perf_event's read_size can overflow, leading to an heap out-of-bounds increment or write in perf_read_group(). We recommend upgrading past commit 382c27f4ed28f803b1f1473ac2d8db0afc795a1b.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 382c27f4ed28f803b1f1473ac2d8db0afc795a1b (unaffected)
Affected range stops below 4.19.302, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.10.204, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.15.143, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.264, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.68, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.6.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.7, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.7.0 (unaffected)
V3.1.0 ≤ v < V3.1.53.1.0
Affected range stops below V3.1.5, so it looks safe — our inference, not a vendor statement
V3.1.0 ≤ v < V3.1.53.1.0
Affected range stops below V3.1.5, so it looks safe — our inference, not a vendor statement
V3.1.0 ≤ v < V3.1.53.1.0
Affected range stops below V3.1.5, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
LOCAL
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-787

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card