CVE-2023-6789

PAN-OS: Stored Cross-Site Scripting (XSS) Vulnerability in the Web Interface

MEDIUM
4.8
CVSS Score
Published: December 13, 2023 at 06:26 PM UTC
Updated: June 17, 2026 at 06:51 AM UTC
1 product affected across 1 vendorPAN-OS

Using PAN-OS by Palo Alto Networks?

Get instant alerts when new vulnerabilities affect PAN-OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.8
Exploit prediction
EPSS 0.4%

Description

A cross-site scripting (XSS) vulnerability in Palo Alto Networks PAN-OS software enables a malicious authenticated read-write administrator to store a JavaScript payload using the web interface. Then, when viewed by a properly authenticated administrator, the JavaScript payload executes and disguises all associated actions as performed by that unsuspecting authenticated administrator.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≥ 10.010.1 ≤ v < 10.1.1110.1.0 ≤ v < 10.1.1110.2 ≤ v < 10.2.510.2.0 ≤ v < 10.2.511.0 ≤ v < 11.0.211.0.0 ≤ v < 11.0.28.1 ≤ v < 8.1.268.1.0 ≤ v < 8.1.269.0 ≤ v < 9.0.17-h49.0.0 ≤ v < 9.0.179.1 ≤ v < 9.1.179.1.0 ≤ v < 9.1.1710.010.110.211.08.19.09.1
Affected range stops below 10.1.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.2.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.0.2, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 11.1 (unaffected)
Affected range stops below 8.1.26, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.17-h4, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1.17, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card