CVE-2023-5631

Stored XSS vulnerability in Roundcube

MEDIUM
5.4
CVSS Score
Published: October 18, 2023 at 02:51 PM UTC
Updated: June 17, 2026 at 06:48 AM UTC
3 products affected across 3 vendorsDebian LinuxFedoraWebmail

Using Roundcubemail by Roundcube?

Get instant alerts when new vulnerabilities affect Roundcubemail - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploitation
CISA KEV
Exploit prediction
EPSS 76%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score76.3%

EPSS (Exploit Prediction Scoring System) estimates a 76.3% chance this CVE is exploited in the wild within the next 30 days — higher than 100% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Roundcube Webmail contains a persistent cross-site scripting (XSS) vulnerability that allows a remote attacker to run malicious JavaScript code.

Required Action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Ransomware Use
Unknown
Added to KEV
Oct 26, 2023
Remediation Due
Nov 16, 2023
1078 days overdue

Description

Roundcube before 1.4.15, 1.5.x before 1.5.5, and 1.6.x before 1.6.4 allows stored XSS via an HTML e-mail message with a crafted SVG document because of program/lib/Roundcube/rcube_washtml.php behavior. This could allow a remote attacker to load arbitrary JavaScript code.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.4.151.4.0 ≤ v < 1.5.141.5.0 ≤ v < 1.5.41.5.0 ≤ v < 1.5.51.6.0 ≤ v < 1.6.31.6.0 ≤ v < 1.6.41.4.01.5.01.6.0
Affected range stops below 1.4.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.5.14, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.5.15 (unaffected)
Affected range stops below 1.5.4, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.5.5 (unaffected)
Affected range stops below 1.6.3, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.6.4 (unaffected)

SSVC — Action Prioritization

SSVCActiveNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card