CVE-2023-53464

scsi: iscsi_tcp: Check that sock is valid before iscsi_set_param()

MEDIUM
5.5
CVSS Score
Published: October 1, 2025 at 11:42 AM UTC
Updated: June 17, 2026 at 06:45 AM UTC
1 product affected across 1 vendorLinux Kernel

Using Linux by Linux?

Get instant alerts when new vulnerabilities affect Linux - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.2%

Description

In the Linux kernel, the following vulnerability has been resolved: scsi: iscsi_tcp: Check that sock is valid before iscsi_set_param() The validity of sock should be checked before assignment to avoid incorrect values. Commit 57569c37f0ad ("scsi: iscsi: iscsi_tcp: Fix null-ptr-deref while calling getpeername()") introduced this change which may lead to inconsistent values of tcp_sw_conn->sendpage and conn->datadgst_en. Fix the issue by moving the position of the assignment.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≥ 5.19.17v ≥ 6.0.35.10.150 ≤ v < 5.10.1785.15.75 ≤ v < 5.15.1075.19.17 ≤ v < 5.205.19.17 ≤ v < 6.06.0.3 ≤ v < 6.16.0.3 ≤ v < 6.1.246.1 ≤ v < 6.1.246.1 ≤ v < 6.2.116.1 ≤ v < 6.36.2 ≤ v < 6.2.110a0b861fce2657ba08ec356a74346b37ca4b20085.10.1505.15.755.19.1757569c37f0add1b6489e1a1563c71519daf732cf6.0.36.16.3 rc16.3 rc26.3 rc36.3 rc46.3 rc5884a788f065578bb640382279a83d1df433b13e6897dbbc57d71e8a34ec1af8e573a142de457da38a26b0658751bb0a3b28386fca715333b104d32a2
Vendor states this is fixed in 48b19b79cfa37b1e50da3b5a8af529f994c08901 (fixed)
Vendor states this is fixed in 499757ad3332e2527254f9ab68dec1da087b1d96 (fixed)
Vendor states this is fixed in 5e5c5f472972c4bc9430adc08b36763a0fa5b9f7 (fixed)
Vendor states this is fixed in 6e06a68fbbfcd8576eee8f7139fa2b13c9b72e91 (fixed)
Vendor states this is fixed in b287e21e73ec23f3788fbe40037c42dbe6e9a9a9 (fixed)
Vendor states this is fixed in 5.10.178 (unaffected)
Vendor states this is fixed in 5.15.107 (unaffected)
Affected range stops below 5.20, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.1 (unaffected)
Vendor states this is fixed in 6.1.24 (unaffected)
Vendor states this is fixed in 6.2.11 (unaffected)
Vendor states this is fixed in 6.3 (unaffected)

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-476

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card