CVE-2023-50726

Users with `create` but not `override` privileges can perform local sync in argo-cd

MEDIUM
6.4
CVSS Score
Published: March 13, 2024 at 08:50 PM UTC
Updated: June 17, 2026 at 06:39 AM UTC
1 product affected across 1 vendorArgo CD

Using argo-cd by argoproj?

Get instant alerts when new vulnerabilities affect argo-cd - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.4
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. "Local sync" is an Argo CD feature that allows developers to temporarily override an Application's manifests with locally-defined manifests. Use of the feature should generally be limited to highly-trusted users, since it allows the user to bypass any merge protections in git. An improper validation bug allows users who have `create` privileges but not `override` privileges to sync local manifests on app creation. All other restrictions, including AppProject restrictions are still enforced. The only restriction which is not enforced is that the manifests come from some approved git/Helm/OCI source. The bug was introduced in 1.2.0-rc1 when the local manifest sync feature was added. The bug has been patched in Argo CD versions 2.10.3, 2.9.8, and 2.8.12. Users are advised to upgrade. Users unable to upgrade may mitigate the risk of branch protection bypass by removing `applications, create` RBAC access. The only way to eliminate the issue without removing RBAC access is to upgrade to a patched version.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.10.3v < 2.8.12v < 2.9.81.2.0 ≤ v < 2.8.122.10.0 ≤ v < 2.10.32.9.0 ≤ v < 2.9.7
Affected range stops below 2.10.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.8.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.9.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.9.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.4MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
NONE
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-269CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card