CVE-2023-50722

XWiki Platform XSS/CSRF Remote Code Execution in XWiki.ConfigurableClass

HIGH
8.8
CVSS Score
Published: December 15, 2023 at 07:02 PM UTC
Updated: June 17, 2026 at 06:39 AM UTC
1 product affected across 1 vendorXwiki

Using xwiki-platform by xwiki?

Get instant alerts when new vulnerabilities affect xwiki-platform - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.7%

Description

XWiki Platform is a generic wiki platform. Starting in 2.3 and prior to versions 14.10.15, 15.5.2, and 15.7-rc-1, there is a reflected XSS or also direct remote code execution vulnerability in the code for displaying configurable admin sections. The code that can be passed through a URL parameter is only executed when the user who is visiting the crafted URL has edit right on at least one configuration section. While any user of the wiki could easily create such a section, this vulnerability doesn't require the attacker to have an account or any access on the wiki. It is sufficient to trick any admin user of the XWiki installation to visit the crafted URL. This vulnerability allows full remote code execution with programming rights and thus impacts the confidentiality, integrity and availability of the whole XWiki installation. This has been fixed in XWiki 14.10.15, 15.5.2 and 15.7RC1. The patch can be manually applied to the document `XWiki.ConfigurableClass`.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 14.10.15v < 15.5.2v < 15.7-rc-115.0 ≤ v < 15.5.22.3 ≤ v < 14.10.515.615.6 rc115.7 rc1
Affected range stops below 14.10.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 14.10.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.5.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.7-rc-1, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79CWE-352

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card