CVE-2023-50379

Apache Ambari: authenticated users could perform command injection to perform RCE

HIGH
8.8
CVSS Score
Published: February 27, 2024 at 08:27 AM UTC
Updated: June 17, 2026 at 06:39 AM UTC
1 product affected across 1 vendorAmbari

Using Apache Ambari by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Ambari - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

Malicious code injection in Apache Ambari in prior to 2.7.8. Users are recommended to upgrade to version 2.7.8, which fixes this issue. Impact: A Cluster Operator can manipulate the request by adding a malicious code injection and gain a root over the cluster main host.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.7.82.7.0 ≤ v ≤ 2.7.72.7.0
Affected range stops below 2.7.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card