CVE-2023-50378

Apache Ambari: Various XSS problems

MEDIUM
6.1
CVSS Score
Published: March 1, 2024 at 02:38 PM UTC
Updated: June 17, 2026 at 06:39 AM UTC
1 product affected across 1 vendorAmbari

Using Apache Ambari by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Ambari - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

Lack of proper input validation and constraint enforcement in Apache Ambari prior to 2.7.8 Impact : As it will be stored XSS, Could be exploited to perform unauthorized actions, varying from data access to session hijacking and delivering malicious payloads. Users are recommended to upgrade to version 2.7.8 which fixes this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.7.0 ≤ v ≤ 2.7.72.7.0
Affected range stops below 2.7.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.1MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card