CVE-2023-49734

Apache Superset: Privilege Escalation Vulnerability

MEDIUM
6.5
CVSS Score
Published: December 19, 2023 at 09:52 AM UTC
Updated: June 17, 2026 at 06:36 AM UTC
1 product affected across 1 vendorSuperset

Using Apache Superset by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Superset - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.9%

Description

An authenticated Gamma user has the ability to create a dashboard and add charts to it, this user would automatically become one of the owners of the charts allowing him to incorrectly have write permissions to these charts.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2 or 2.1.3, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.1.23.0.0 ≤ v < 3.0.23.0.0
Affected range stops below 2.1.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.0.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card