CVE-2023-49285

Denial of Service in HTTP Message Processing in Squid

HIGH
7.5
CVSS Score
Published: December 4, 2023 at 10:56 PM UTC
Updated: June 17, 2026 at 06:35 AM UTC
2 products affected across 1 vendorSquidCache Squid

Using squid by squid-cache?

Get instant alerts when new vulnerabilities affect squid - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 88%

Description

Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to a Buffer Overread bug Squid is vulnerable to a Denial of Service attack against Squid HTTP Message processing. This bug is fixed by Squid version 6.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 6.4
Affected range stops below 6.5, so it looks safe — our inference, not a vendor statement
v ≤ 6.4
Affected range stops below 6.5, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-126CWE-125

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card