CVE-2023-49282

Test code in published microsoft-graph package exposes phpinfo()

MEDIUM
5.3
CVSS Score
Published: December 5, 2023 at 10:40 PM UTC
Updated: June 17, 2026 at 06:35 AM UTC
2 products affected across 2 vendorsGraphGraph

Using msgraph-sdk-php by microsoftgraph?

Get instant alerts when new vulnerabilities affect msgraph-sdk-php - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 2%

Description

msgraph-sdk-php is the Microsoft Graph Library for PHP. The Microsoft Graph PHP SDK published packages which contained test code that enabled the use of the phpInfo() function from any application that could access and execute the file at vendor/microsoft/microsoft-graph/tests/GetPhpInfo.php. The phpInfo function exposes system information. The vulnerability affects the GetPhpInfo.php script of the PHP SDK which contains a call to the phpinfo() function. This vulnerability requires a misconfiguration of the server to be present so it can be exploited. For example, making the PHP application’s /vendor directory web accessible. The combination of the vulnerability and the server misconfiguration would allow an attacker to craft an HTTP request that executes the phpinfo() method. The attacker would then be able to get access to system information like configuration, modules, and environment variables and later on use the compromised secrets to access additional data. This problem has been patched in versions 1.109.1 and 2.0.0-RC5. If an immediate deployment with the updated vendor package is not available, you can perform the following temporary workarounds: delete the `vendor/microsoft/microsoft-graph/tests/GetPhpInfo.php` file, remove access to the `/vendor` directory, or disable the phpinfo function.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.16.0 ≤ v < 1.109.12.0.0 ≤ v < 2.0.1
Affected range stops below 1.109.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.1, so it looks safe — our inference, not a vendor statement
v < 1.109.1v < 2.0.1
Affected range stops below 1.109.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.1, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-200NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card