CVE-2023-48705

nautobot has XSS potential in custom links, job buttons, and computed fields

MEDIUM
5.4
CVSS Score
Published: November 22, 2023 at 03:15 PM UTC
Updated: June 17, 2026 at 06:34 AM UTC
2 products affected across 2 vendorsNautobotNautobot

Using nautobot by nautobot?

Get instant alerts when new vulnerabilities affect nautobot - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.5%

Description

Nautobot is a Network Source of Truth and Network Automation Platform built as a web application All users of Nautobot versions earlier than 1.6.6 or 2.0.5 are potentially affected by a cross-site scripting vulnerability. Due to incorrect usage of Django's `mark_safe()` API when rendering certain types of user-authored content; including custom links, job buttons, and computed fields; it is possible that users with permission to create or edit these types of content could craft a malicious payload (such as JavaScript code) that would be executed when rendering pages containing this content. The maintainers have fixed the incorrect uses of `mark_safe()` (generally by replacing them with appropriate use of `format_html()` instead) to prevent such malicious data from being executed. Users on Nautobot 1.6.x LTM should upgrade to v1.6.6 and users on Nautobot 2.0.x should upgrade to v2.0.5. Appropriate object permissions can and should be applied to restrict which users are permitted to create or edit the aforementioned types of user-authored content. Other than that, there is no direct workaround available.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.6.62.0.0 ≤ v < 2.0.5
Affected range stops below 1.6.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.5, so it looks safe — our inference, not a vendor statement
v < 1.6.6v < 2.0.5
Affected range stops below 1.6.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.5, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card