CVE-2023-48240

XWiki Platform sends cookies to external images in rendered diff and is vulnerable to server side request forgery

HIGH
8.8
CVSS Score
Published: November 20, 2023 at 05:48 PM UTC
Updated: June 17, 2026 at 06:33 AM UTC
1 product affected across 1 vendorXwiki

Using xwiki-platform by xwiki?

Get instant alerts when new vulnerabilities affect xwiki-platform - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.7%

Description

XWiki Platform is a generic wiki platform. The rendered diff in XWiki embeds images to be able to compare the contents and not display a difference for an actually unchanged image. For this, XWiki requests all embedded images on the server side. These requests are also sent for images from other domains and include all cookies that were sent in the original request to ensure that images with restricted view right can be compared. Starting in version 11.10.1 and prior to versions 14.10.15, 15.5.1, and 15.6, this allows an attacker to steal login and session cookies that allow impersonating the current user who views the diff. The attack can be triggered with an image that references the rendered diff, thus making it easy to trigger. Apart from stealing login cookies, this also allows server-side request forgery (the result of any successful request is returned in the image's source) and viewing protected content as once a resource is cached, it is returned for all users. As only successful requests are cached, the cache will be filled by the first user who is allowed to access the resource. This has been patched in XWiki 14.10.15, 15.5.1 and 15.6. The rendered diff now only downloads images from trusted domains. Further, cookies are only sent when the image's domain is the same the requested domain. The cache has been changed to be specific for each user. As a workaround, the image embedding feature can be disabled by deleting `xwiki-platform-diff-xml-<version>.jar` in `WEB-INF/lib/`.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 14.10.15v < 15.5.1v < 15.611.10.1 ≤ v < 14.10.1515.0 ≤ v < 15.5.115.6 rc1
Affected range stops below 14.10.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.5.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.6, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-201CWE-281CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card