CVE-2023-48239

Nextcloud Server users can make external storage mount points inaccessible for other users

HIGH
7.1
CVSS Score
Published: November 21, 2023 at 09:02 PM UTC
Updated: June 17, 2026 at 06:33 AM UTC
1 product affected across 1 vendorNextcloud/server

Using security-advisories by nextcloud?

Get instant alerts when new vulnerabilities affect security-advisories - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.1
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

Nextcloud Server provides data storage for Nextcloud, an open source cloud platform. Starting in version 25.0.0 and prior to versions 25.0.13, 26.0.8, and 27.1.3 of Nextcloud Server and starting in version 20.0.0 and prior to versions 20.0.14.16, 21.0.9.13, 22.2.10.15, 23.0.12.12, 24.0.12.8, 25.0.13, 26.0.8, and 27.1.3 of Nextcloud Enterprise Server, a malicious user could update any personal or global external storage, making them inaccessible for everyone else as well. Nextcloud Server 25.0.13, 26.0.8, and 27.1.3 and Nextcloud Enterprise Server is upgraded to 20.0.14.16, 21.0.9.13, 22.2.10.15, 23.0.12.12, 24.0.12.8, 25.0.13, 26.0.8, and 27.1.3 contain a patch for this issue. As a workaround, disable app files_external. This workaround also makes the external storage inaccessible but retains the configurations until a patched version has been deployed.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

20.0.0 ≤ v < 20.0.14.1621.0.0 ≤ v < 21.0.9.1322.0.0 ≤ v < 22.2.10.1523.0.0 ≤ v < 23.0.12.1224.0.0 ≤ v < 24.0.12.825.0.0 ≤ v < 25.0.1326.0.0 ≤ v < 26.0.827.0.0 ≤ v < 27.1.3
Affected range stops below 20.0.14.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.0.9.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2.10.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 23.0.12.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.0.12.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.0.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 26.0.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 27.1.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-284NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card