CVE-2023-48218

Strapi Protected Populate Plugin leaking fields if the request fields where empty or only fields selected where not populatable

MEDIUM
5.3
CVSS Score
Published: November 20, 2023 at 05:09 PM UTC
Updated: June 17, 2026 at 06:33 AM UTC
2 products affected across 2 vendorsProtected PopulateProtected Populate

Using strapi-plugin-protected-populate by strapi-community?

Get instant alerts when new vulnerabilities affect strapi-plugin-protected-populate - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 0.6%

Description

The Strapi Protected Populate Plugin protects `get` endpoints from revealing too much information. Prior to version 1.3.4, users were able to bypass the field level security. Users who tried to populate something that they didn't have access to could populate those fields anyway. This issue has been patched in version 1.3.4. There are no known workarounds.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.3.4
Affected range stops below 1.3.4, so it looks safe — our inference, not a vendor statement
v < 1.3.4
Affected range stops below 1.3.4, so it looks safe — our inference, not a vendor statement

CVSS

5.3MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card