CVE-2023-46729

Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint

MEDIUM
6.1
CVSS Score
Published: November 10, 2023 at 12:57 AM UTC
Updated: June 17, 2026 at 06:31 AM UTC
2 products affected across 2 vendorsSentry Software Development KitSentry JavaScript

Using sentry-javascript by getsentry?

Get instant alerts when new vulnerabilities affect sentry-javascript - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

sentry-javascript provides Sentry SDKs for JavaScript. An unsanitized input of Next.js SDK tunnel endpoint allows sending HTTP requests to arbitrary URLs and reflecting the response back to the user. This issue only affects users who have Next.js SDK tunneling feature enabled. The problem has been fixed in version 7.77.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

7.26.0 ≤ v < 7.77.0
Affected range stops below 7.77.0, so it looks safe — our inference, not a vendor statement
v < 7.77.0
Affected range stops below 7.77.0, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card