CVE-2023-46131

Grails® data binding causes JVM crash and/or DoS

HIGH
7.5
CVSS Score
Published: December 20, 2023 at 11:24 PM UTC
Updated: June 17, 2026 at 06:30 AM UTC
1 product affected across 1 vendorGrails

Using grails-core by grails?

Get instant alerts when new vulnerabilities affect grails-core - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.7%

Description

Grails is a framework used to build web applications with the Groovy programming language. A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable. This issue has been patched in version 3.3.17, 4.1.3, 5.3.4, 6.1.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.3.17v < 4.1.3v < 5.3.4v < 6.1.04.0.0 ≤ v < 4.1.35.0.0 ≤ v < 5.3.46.0.0 ≤ v < 6.1.0
Affected range stops below 3.3.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.3.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.0, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-400NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card