CVE-2023-4504

OpenPrinting CUPS/libppd Postscript Parsing Heap Overflow

HIGH
7
CVSS Score
Published: September 21, 2023 at 10:47 PM UTC
Updated: June 17, 2026 at 06:37 AM UTC
4 products affected across 3 vendorsDebian LinuxFedoraCUPS

Using CUPS by OpenPrinting?

Get instant alerts when new vulnerabilities affect CUPS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7
Exploit prediction
EPSS 0.6%
SSVC
PoC

Description

Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.4.6v < 2.4.7
Affected range stops below 2.4.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.4.7, so it looks safe — our inference, not a vendor statement
v < d09348b2.0 rc2
Affected range stops below d09348b, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7HIGHCISA-ADP
Attack Vector
LOCAL
Complexity
HIGH
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-122CWE-787

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card