CVE-2023-42916

MEDIUM
6.5
CVSS Score
Published: November 30, 2023 at 10:18 PM UTC
Updated: June 17, 2026 at 06:24 AM UTC
7 products affected across 4 vendorsmacOSDebian LinuxFedora

Using Safari by Apple?

Get instant alerts when new vulnerabilities affect Safari - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploitation
CISA KEV
Exploit prediction
EPSS 18%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score17.8%

EPSS (Exploit Prediction Scoring System) estimates a 17.8% chance this CVE is exploited in the wild within the next 30 days — higher than 97% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Apple iOS, iPadOS, macOS, and Safari WebKit contain an out-of-bounds read vulnerability that may disclose sensitive information when processing maliciously crafted web content. This vulnerability could impact HTML parsers that use WebKit, including but not limited to Apple Safari and non-Apple products which rely on WebKit for HTML processing.

Required Action
Apply remediations or mitigations per vendor instructions or discontinue use of the product if remediation or mitigations are unavailable.
Ransomware Use
Unknown
Added to KEV
Dec 4, 2023
Remediation Due
Dec 25, 2023
1036 days overdue

Description

An out-of-bounds read was addressed with improved input validation. This issue is fixed in iOS 17.1.2 and iPadOS 17.1.2, macOS Sonoma 14.1.2, Safari 17.1.2. Processing web content may disclose sensitive information. Apple is aware of a report that this issue may have been exploited against versions of iOS before iOS 16.7.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 15.8.1v < 17.1v < 17.1.216.0 ≤ v < 16.7.317.0 ≤ v < 17.1.2
Affected range stops below 15.8.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.7.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.1.2, so it looks safe — our inference, not a vendor statement
v < 15.8.1v < 17.1.216.0 ≤ v < 16.7.317.0 ≤ v < 17.1.2
Affected range stops below 15.8.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.7.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.1.2, so it looks safe — our inference, not a vendor statement
v < 14.114.0 ≤ v < 14.1.214.0.0 ≤ v < 14.1.214.0.0
Affected range stops below 14.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 14.1.2, so it looks safe — our inference, not a vendor statement
v < 17.1v < 17.1.2
Affected range stops below 17.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.1.2, so it looks safe — our inference, not a vendor statement
v < 2.42.3
Affected range stops below 2.42.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (19)

SSVC — Action Prioritization

SSVCActiveNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-125

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card