CVE-2023-42899

HIGH
7.8
CVSS Score
Published: December 12, 2023 at 12:27 AM UTC
Updated: June 17, 2026 at 06:24 AM UTC
5 products affected across 1 vendormacOSiPhone OSiPadOS

Using iOS and iPadOS by Apple?

Get instant alerts when new vulnerabilities affect iOS and iPadOS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 0.4%

Description

The issue was addressed with improved memory handling. This issue is fixed in macOS Sonoma 14.2, iOS 17.2 and iPadOS 17.2, watchOS 10.2, macOS Ventura 13.6.3, tvOS 17.2, iOS 16.7.3 and iPadOS 16.7.3, macOS Monterey 12.7.2. Processing an image may lead to arbitrary code execution.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 16.7v < 16.7.3v < 17.217.0 ≤ v < 17.2
Affected range stops below 16.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.7.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.2, so it looks safe — our inference, not a vendor statement
v < 16.7.317.0 ≤ v < 17.2
Affected range stops below 16.7.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.2, so it looks safe — our inference, not a vendor statement
v < 12.7v < 13.6v < 14.212.0.0 ≤ v < 12.7.213.0 ≤ v < 13.6.314.0 ≤ v < 14.2
Affected range stops below 12.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.7.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 13.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 13.6.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 14.2, so it looks safe — our inference, not a vendor statement
v < 10.2v < 17.2
Affected range stops below 10.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.2, so it looks safe — our inference, not a vendor statement
v < 10.2
Affected range stops below 10.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (19)

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card