CVE-2023-40032

Potential segfault due to NULL pointer dereference in libvips

MEDIUM
5.5
CVSS Score
Published: September 11, 2023 at 06:34 PM UTC
Updated: June 17, 2026 at 06:15 AM UTC
2 products affected across 2 vendorsFedoraLibvips

Using libvips by libvips?

Get instant alerts when new vulnerabilities affect libvips - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.3%

Description

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 8.14.48.12.0 ≤ v < 8.14.4
Affected range stops below 8.14.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

5.5MEDIUMGitHub_M
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-476

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card