CVE-2023-38510

Tolgee Lacks Permission Check for API Key for some endpoints

HIGH
8.1
CVSS Score
Published: July 27, 2023 at 06:57 PM UTC
Updated: June 17, 2026 at 06:10 AM UTC
1 product affected across 1 vendorTolgee

Using tolgee-platform by tolgee?

Get instant alerts when new vulnerabilities affect tolgee-platform - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.1
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

Tolgee is an open-source localization platform. Starting in version 3.14.0 and prior to version 3.23.1, when a request is made using an API key, the backend fails to verify the permission scopes associated with the key, effectively bypassing permission checks entirely for some endpoints. It's important to note that this vulnerability only affects projects that have inadvertently exposed their API keys on the internet. Projects that have kept their API keys secure are not impacted. This issue is fixed in version 3.23.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.23.13.14.0 ≤ v < 3.23.13.14.0
Affected range stops below 3.23.1, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.1HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-862

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card