CVE-2023-38492

Kirby vulnerable to denial of service from unlimited password lengths

HIGH
7.5
CVSS Score
Published: July 27, 2023 at 03:43 PM UTC
Updated: June 17, 2026 at 06:10 AM UTC
1 product affected across 1 vendorKirby

Using kirby by getkirby?

Get instant alerts when new vulnerabilities affect kirby - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 affects all Kirby sites with user accounts (unless Kirby's API and Panel are disabled in the config). The real-world impact of this vulnerability is limited, however we still recommend to update to one of the patch releases because they also fix more severe vulnerabilities. Kirby's authentication endpoint did not limit the password length. This allowed attackers to provide a password with a length up to the server's maximum request body length. Validating that password against the user's actual password requires hashing the provided password, which requires more CPU and memory resources (and therefore processing time) the longer the provided password gets. This could be abused by an attacker to cause the website to become unresponsive or unavailable. Because Kirby comes with a built-in brute force protection, the impact of this vulnerability is limited to 10 failed logins from each IP address and 10 failed logins for each existing user per hour. The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have added password length limits in the affected code so that passwords longer than 1000 bytes are immediately blocked, both when setting a password and when logging in.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
v < 3.5.8.3v < 3.6.6.3v < 3.7.5.2v < 3.8.41v < 3.9.63.5.0 ≤ v < 3.5.8.33.6.0 ≤ v < 3.6.6.33.7.0 ≤ v < 3.7.5.23.8.0 ≤ v < 3.8.4.13.9.0 ≤ v < 3.9.6
Affected range stops below 3.5.8.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.6.6.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.7.5.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.8.4.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.9.6, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-770

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card