CVE-2023-38489

Kirby vulnerable to Insufficient Session Expiration after a password change

HIGH
7.3
CVSS Score
Published: July 27, 2023 at 02:36 PM UTC
Updated: June 17, 2026 at 06:10 AM UTC
1 product affected across 1 vendorKirby

Using kirby by getkirby?

Get instant alerts when new vulnerabilities affect kirby - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.3
Exploit prediction
EPSS 0.8%
SSVC
No known exploit

Description

Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 affects all Kirby sites with user accounts (unless Kirby's API and Panel are disabled in the config). It can only be abused if a Kirby user is logged in on a device or browser that is shared with potentially untrusted users or if an attacker already maliciously used a previous password to log in to a Kirby site as the affected user. Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization. In the variation described in this advisory, it allows attackers to stay logged in to a Kirby site on another device even if the logged in user has since changed their password. Kirby did not invalidate user sessions that were created with a password that was since changed by the user or by a site admin. If a user changed their password to lock out an attacker who was already in possession of the previous password or of a login session on another device or browser, the attacker would not be reliably prevented from accessing the Kirby site as the affected user. The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have updated the authentication implementation to keep track of the hashed password in each active session. If the password changed since the login, the session is invalidated. To enforce this fix even if the vulnerability was previously abused, all users are logged out from the Kirby site after updating to one of the patched releases.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
v < 3.5.8.3v < 3.6.6.3v < 3.7.5.2v < 3.8.41v < 3.9.63.5.0 ≤ v < 3.5.8.33.6.0 ≤ v < 3.6.6.33.60 ≤ v < 3.6.6.33.7.0 ≤ v < 3.7.5.23.70 ≤ v < 3.7.5.23.8.0 ≤ v < 3.8.4.13.8.0 ≤ v < 3.8.413.9.0 ≤ v < 3.9.63.603.703.8.03.9.0
Affected range stops below 3.5.8.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.6.6.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.7.5.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.8.4.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.9.6, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.3HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-613

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card