CVE-2023-37450

HIGH
8.8
CVSS Score
Published: July 26, 2023 at 11:21 PM UTC
Updated: June 17, 2026 at 06:08 AM UTC
7 products affected across 2 vendorsmacOSiPhone OSiPadOS

Using Safari by Apple?

Get instant alerts when new vulnerabilities affect Safari - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploitation
CISA KEV
Exploit prediction
EPSS 19%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score18.9%

EPSS (Exploit Prediction Scoring System) estimates a 18.9% chance this CVE is exploited in the wild within the next 30 days — higher than 97% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Apple iOS, iPadOS, macOS, and Safari WebKit contain an unspecified vulnerability that leads to code execution when processing maliciously crafted web content. This vulnerability could impact HTML parsers that use WebKit, including but not limited to Apple Safari and non-Apple products which rely on WebKit for HTML processing.

Required Action
Apply updates per vendor instructions or discontinue use of the product if updates are unavailable.
Ransomware Use
Unknown
Added to KEV
Jul 13, 2023
Remediation Due
Aug 3, 2023
1186 days overdue

Description

The issue was addressed with improved checks. This issue is fixed in iOS 16.6 and iPadOS 16.6, Safari 16.5.2, tvOS 16.6, macOS Ventura 13.5, watchOS 9.6. Processing web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 16.6
Affected range stops below 16.6, so it looks safe — our inference, not a vendor statement
v < 16.6
Affected range stops below 16.6, so it looks safe — our inference, not a vendor statement
v < 13.513.0 ≤ v < 13.5
Affected range stops below 13.5, so it looks safe — our inference, not a vendor statement
v < 16.5v < 16.5.2
Affected range stops below 16.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.5.2, so it looks safe — our inference, not a vendor statement
v < 16.6
Affected range stops below 16.6, so it looks safe — our inference, not a vendor statement
v < 9.6
Affected range stops below 9.6, so it looks safe — our inference, not a vendor statement
v < 2.42.3
Affected range stops below 2.42.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCActiveNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card