CVE-2023-37257

The DataEase panel and dataset have a stored XSS vulnerability

MEDIUM
5.4
CVSS Score
Published: July 25, 2023 at 07:04 PM UTC
Updated: June 17, 2026 at 06:07 AM UTC
1 product affected across 1 vendorDataease

Using dataease by dataease?

Get instant alerts when new vulnerabilities affect dataease - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.4%
SSVC
PoC

Description

DataEase is an open source data visualization analysis tool. Prior to version 1.18.9, the DataEase panel and dataset have a stored cross-site scripting vulnerability. The vulnerability has been fixed in v1.18.9. There are no known workarounds.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.18.9
Affected range stops below 1.18.9, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.4MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card