CVE-2023-36478

HTTP/2 HPACK integer overflow and buffer allocation

HIGH
7.5
CVSS Score
Published: October 10, 2023 at 04:53 PM UTC
Updated: June 17, 2026 at 06:06 AM UTC
3 products affected across 3 vendorsDebian LinuxJenkinsJetty

Using jetty.project by eclipse?

Get instant alerts when new vulnerabilities affect jetty.project - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 5%

Description

Eclipse Jetty provides a web server and servlet container. In versions 11.0.0 through 11.0.15, 10.0.0 through 10.0.15, and 9.0.0 through 9.4.52, an integer overflow in `MetaDataBuilder.checkSize` allows for HTTP/2 HPACK header values to exceed their size limit. `MetaDataBuilder.java` determines if a header name or value exceeds the size limit, and throws an exception if the limit is exceeded. However, when length is very large and huffman is true, the multiplication by 4 in line 295 will overflow, and length will become negative. `(_size+length)` will now be negative, and the check on line 296 will not be triggered. Furthermore, `MetaDataBuilder.checkSize` allows for user-entered HPACK header value sizes to be negative, potentially leading to a very large buffer allocation later on when the user-entered size is multiplied by 2. This means that if a user provides a negative length value (or, more precisely, a length value which, when multiplied by the 4/3 fudge factor, is negative), and this length value is a very large positive number when multiplied by 2, then the user can cause a very large buffer to be allocated on the server. Users of HTTP/2 can be impacted by a remote denial of service attack. The issue has been fixed in versions 11.0.16, 10.0.16, and 9.4.53. There are no known workarounds.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 10.0.16v < 11.0.16v < 9.4.5310.0.0 ≤ v < 10.0.1611.0.0 ≤ v < 11.0.169.3.0 ≤ v < 9.4.53
Affected range stops below 10.0.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.0.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.4.53, so it looks safe — our inference, not a vendor statement
Jenkins· Jenkinsjenkins-plugin
95%
v < 2.414.3v < 2.428
Affected range stops below 2.414.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.428, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

7.5HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-190CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card