CVE-2023-36471

HTML sanitizer allows form elements in restricted in org.xwiki.commons:xwiki-commons-xml

MEDIUM
5.4
CVSS Score
Published: June 29, 2023 at 07:44 PM UTC
Updated: June 17, 2026 at 06:06 AM UTC
2 products affected across 1 vendorCommonsXwiki

Using xwiki-commons by xwiki?

Get instant alerts when new vulnerabilities affect xwiki-commons - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 1%
SSVC
PoC

Description

Xwiki commons is the common modules used by other XWiki top level projects. The HTML sanitizer that is included in XWiki since version 14.6RC1 allowed form and input HTML tags. In the context of XWiki, this allows an attacker without script right to either create forms that can be used for phishing attacks or also in the context of a sheet, the attacker could add an input like `{{html}}<input type="hidden" name="content" value="{{groovy}}println(&quot;Hello from Groovy!&quot;)" />{{/html}}` that would allow remote code execution when it is submitted by an admin (the sheet is rendered as part of the edit form). The attacker would need to ensure that the edit form looks plausible, though, which can be non-trivial as without script right the attacker cannot display the regular content of the document. This has been patched in XWiki 14.10.6 and 15.2RC1 by removing the central form-related tags from the list of allowed tags. Users are advised to upgrade. As a workaround an admin can manually disallow the tags by adding `form, input, select, textarea, button` to the configuration option `xml.htmlElementSanitizer.forbidTags` in the `xwiki.properties` configuration file.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

14.6 ≤ v < 14.10.615.015.0 rc115.115.1 rc1
Affected range stops below 14.10.6, so it looks safe — our inference, not a vendor statement
v < 14.10.6v < 15.2-rc-1
Affected range stops below 14.10.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.2-rc-1, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-74CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card