CVE-2023-3609

Use-after-free in Linux kernel's net/sched: cls_u32 component

HIGH
7.8
CVSS Score
Published: July 21, 2023 at 08:47 PM UTC
Updated: October 14, 2026 at 09:17 PM UTC
2 products affected across 2 vendorsLinux KernelDebian Linux

Using Kernel by Linux?

Get instant alerts when new vulnerabilities affect Kernel - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

A use-after-free vulnerability in the Linux kernel's net/sched: cls_u32 component can be exploited to achieve local privilege escalation. If tcf_change_indev() fails, u32_set_parms() will immediately return an error after incrementing or decrementing the reference counter in tcf_bind_filter(). If an attacker can control the reference counter and set it to zero, they can cause the reference to be freed, leading to a use-after-free vulnerability. We recommend upgrading past commit 04c55383fa5689357bcdd2c8036725a55ed632bc.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.14 ≤ v < 4.14.3224.15 ≤ v < 4.19.2914.20 ≤ v < 5.4.2485.11 ≤ v < 5.15.1185.16 ≤ v < 6.1.355.5 ≤ v < 5.10.1856.2 ≤ v < 6.3.94.14.04.15.04.20.05.11.05.16.05.5.06.2.06.46.4 rc16.4 rc26.4 rc36.4 rc46.4 rc56.4 rc6
Vendor states this is fixed in 04c55383fa5689357bcdd2c8036725a55ed632bc (unaffected)
Affected range stops below 4.14.322, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.19.291, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4c55383fa5689357bcdd2c8036725a55ed632bc (unaffected)
Affected range stops below 5.10.185, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.15.118, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.248, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.35, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.3.9, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.4.0 (unaffected)

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.8HIGHGoogle
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-416

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card