CVE-2023-35928

Nextcloud user scoped external storage can be used to gather credentials of other users

HIGH
8.8
CVSS Score
Published: June 23, 2023 at 08:58 PM UTC
Updated: June 17, 2026 at 06:05 AM UTC
1 product affected across 1 vendorNextcloud/server

Using security-advisories by nextcloud?

Get instant alerts when new vulnerabilities affect security-advisories - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 1.0%
SSVC
No known exploit

Description

Nextcloud Server is a space for data storage on Nextcloud, a self-hosted productivity playform. In NextCloud Server versions 25.0.0 until 25.0.7 and 26.0.0 until 26.0.2 and Nextcloud Enterprise Server versions 19.0.0 until 19.0.13.9, 20.0.0 until 20.0.14.14, 21.0.0 until 21.0.9.12, 22.0.0 until 22.2.10.12, 23.0.0 until 23.0.12.7, 24.0.0 until 24.0.12.2, 25.0.0 until 25.0.7, and 26.0.0 until 26.0.2, a user could use this functionality to get access to the login credentials of another user and take over their account. This issue has been patched in Nextcloud Server versions 25.0.7 and 26.0.2 and NextCloud Enterprise Server versions 19.0.13.9, 20.0.14.14, 21.0.9.12, 22.2.10.12, 23.0.12.7, 24.0.12.2, 25.0.7, and 26.0.2. Three workarounds are available. Disable app files_external. Change config setting "Allow users to mount external storage" to disabled in "Administration" > "External storage" settings `…/index.php/settings/admin/externalstorages`. Change config setting to disallow users to create external storages in "Administration" > "External storage" settings `…/index.php/settings/admin/externalstorages` with the types FTP, Nextcloud, SFTP, and/or WebDAV.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

19.0.0 ≤ v < 19.0.13.920.0.0 ≤ v < 20.0.14.1421.0.0 ≤ v < 21.0.9.1222.0.0 ≤ v < 22.2.10.1223.0.0 ≤ v < 23.0.12.724.0.0 ≤ v < 24.0.12.225.0.0 ≤ v < 25.0.726.0.0 ≤ v < 26.0.2
Affected range stops below 19.0.13.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.0.14.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.0.9.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2.10.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 23.0.12.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.0.12.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.0.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 26.0.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-274NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card