CVE-2023-35165

AWS CDK EKS overly permissive trust policies

HIGH
8.8
CVSS Score
Published: June 23, 2023 at 08:32 PM UTC
Updated: June 17, 2026 at 06:04 AM UTC
2 products affected across 2 vendorsAWS Cloud Development KitAWS Cloud Development Kit (CDK)

Using aws-cdk by aws?

Get instant alerts when new vulnerabilities affect aws-cdk - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

AWS Cloud Development Kit (AWS CDK) is an open-source software development framework to define cloud infrastructure in code and provision it through AWS CloudFormation. In the packages `aws-cdk-lib` 2.0.0 until 2.80.0 and `@aws-cdk/aws-eks` 1.57.0 until 1.202.0, `eks.Cluster` and `eks.FargateCluster` constructs create two roles, `CreationRole` and `default MastersRole`, that have an overly permissive trust policy. The first, referred to as the `CreationRole`, is used by lambda handlers to create the cluster and deploy Kubernetes resources (e.g `KubernetesManifest`, `HelmChart`, ...) onto it. Users with CDK version higher or equal to 1.62.0 (including v2 users) may be affected. The second, referred to as the `default MastersRole`, is provisioned only if the `mastersRole` property isn't provided and has permissions to execute `kubectl` commands on the cluster. Users with CDK version higher or equal to 1.57.0 (including v2 users) may be affected. The issue has been fixed in `@aws-cdk/aws-eks` v1.202.0 and `aws-cdk-lib` v2.80.0. These versions no longer use the account root principal. Instead, they restrict the trust policy to the specific roles of lambda handlers that need it. There is no workaround available for CreationRole. To avoid creating the `default MastersRole`, use the `mastersRole` property to explicitly provide a role.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.57.0 ≤ v < 1.202.02.0.0 ≤ v < 2.80.0
Affected range stops below 1.202.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.80.0, so it looks safe — our inference, not a vendor statement
v < 1.202.0v < 2.80.0
Affected range stops below 1.202.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.80.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

x_refsource_MISCIssue TrackingMitigationThird Party Advisory
https://github.com/aws/aws-cdk/issues/25674
x_refsource_CONFIRMExploitMitigationThird Party Advisory
https://github.com/aws/aws-cdk/security/advisories/GHSA-rx28-r23p-2qc3

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card