CVE-2023-34110

Flask-AppBuilder vulnerable to possible disclosure of sensitive information on user error

LOW
2.7
CVSS Score
Published: June 22, 2023 at 10:34 PM UTC
Updated: June 17, 2026 at 06:02 AM UTC
2 products affected across 2 vendorsFlask AppbuilderFlask-AppBuilder

Using Flask-AppBuilder by dpgaspar?

Get instant alerts when new vulnerabilities affect Flask-AppBuilder - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW2.7
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.3.2
Affected range stops below 4.3.2, so it looks safe — our inference, not a vendor statement
v < 4.3.2
Affected range stops below 4.3.2, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

2.7LOWGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-209

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card