CVE-2023-32373

HIGH
8.8
CVSS Score
Published: June 23, 2023 at 12:00 AM UTC
Updated: June 17, 2026 at 05:58 AM UTC
8 products affected across 3 vendorsmacOSiPhone OSEnterprise Linux

Using macOS by Apple?

Get instant alerts when new vulnerabilities affect macOS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploitation
CISA KEV
Exploit prediction
EPSS 12%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score12.2%

EPSS (Exploit Prediction Scoring System) estimates a 12.2% chance this CVE is exploited in the wild within the next 30 days — higher than 96% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Apple iOS, iPadOS, macOS, tvOS, watchOS, and Safari WebKit contain a use-after-free vulnerability that leads to code execution when processing maliciously crafted web content. This vulnerability could impact HTML parsers that use WebKit, including but not limited to Apple Safari and non-Apple products which rely on WebKit for HTML processing.

Required Action
Apply updates per vendor instructions.
Ransomware Use
Unknown
Added to KEV
May 22, 2023
Remediation Due
Jun 12, 2023
1235 days overdue

Description

A use-after-free issue was addressed with improved memory management. This issue is fixed in watchOS 9.5, tvOS 16.5, macOS Ventura 13.4, iOS 15.7.6 and iPadOS 15.7.6, Safari 16.5, iOS 16.5 and iPadOS 16.5. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 15.7v < 15.7.6v < 16.516.0 ≤ v < 16.5
Affected range stops below 15.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.7.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.5, so it looks safe — our inference, not a vendor statement
15.0 ≤ v < 15.7.616.0 ≤ v < 16.5
Affected range stops below 15.7.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.5, so it looks safe — our inference, not a vendor statement
v < 13.4
Affected range stops below 13.4, so it looks safe — our inference, not a vendor statement
v < 16.5
Affected range stops below 16.5, so it looks safe — our inference, not a vendor statement
v < 16.5
Affected range stops below 16.5, so it looks safe — our inference, not a vendor statement
v < 9.5
Affected range stops below 9.5, so it looks safe — our inference, not a vendor statement
v < 2.42.3
Affected range stops below 2.42.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCActiveNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-416

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card