CVE-2023-32325

Cross-site scripting in PostHog-js

MEDIUM
6.1
CVSS Score
Published: May 26, 2023 at 11:00 PM UTC
Updated: June 17, 2026 at 05:58 AM UTC
1 product affected across 1 vendorPosthog Js

Using posthog-js by PostHog?

Get instant alerts when new vulnerabilities affect posthog-js - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

PostHog-js is a library to interface with the PostHog analytics tool. Versions prior to 1.57.2 have the potential for cross-site scripting. Problem has been patched in 1.57.2. Users are advised to upgrade. Users unable to upgrade should ensure that their Content Security Policy is in place.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.57.2
Affected range stops below 1.57.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card