CVE-2023-32315

Openfire administration console authentication bypass

HIGH
7.5
CVSS Score
Published: May 26, 2023 at 10:33 PM UTC
Updated: June 17, 2026 at 05:58 AM UTC
1 product affected across 1 vendorOpenfire

Using Openfire by igniterealtime?

Get instant alerts when new vulnerabilities affect Openfire - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploitation
CISA KEV
Exploit prediction
EPSS 100%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score100.0%

EPSS (Exploit Prediction Scoring System) estimates a 100.0% chance this CVE is exploited in the wild within the next 30 days — higher than 100% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Ignite Realtime Openfire contains a path traversal vulnerability that allows an unauthenticated attacker to access restricted pages in the Openfire Admin Console reserved for administrative users.

Required Action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Ransomware Use
Unknown
Added to KEV
Aug 24, 2023
Remediation Due
Sep 14, 2023
1142 days overdue

Description

Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.6.8v < 4.7.53.10.0 ≤ v < 4.6.84.7.0 ≤ v < 4.7.5
Affected range stops below 4.6.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.5, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCActiveAutomatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card