CVE-2023-31145

Reflected XSS vulnerability in CollaboraOnline

MEDIUM
6.1
CVSS Score
Published: May 15, 2023 at 08:58 PM UTC
Updated: June 17, 2026 at 05:56 AM UTC
2 products affected across 2 vendorsOnlineOnline

Using online by CollaboraOnline?

Get instant alerts when new vulnerabilities affect online - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Collabora Online is a collaborative online office suite based on LibreOffice technology. This vulnerability report describes a reflected XSS vulnerability with full CSP bypass in Nextcloud installations using the recommended bundle. The vulnerability can be exploited to perform a trivial account takeover attack. The vulnerability allows attackers to inject malicious code into web pages, which can be executed in the context of the victim's browser session. This means that an attacker can steal sensitive data, such as login credentials or personal information, or perform unauthorized actions on behalf of the victim, such as modifying or deleting data. In this specific case, the vulnerability allows for a trivial account takeover attack. An attacker can exploit the vulnerability to inject code into the victim's browser session, allowing the attacker to take over the victim's account without their knowledge or consent. This can lead to unauthorized access to sensitive information and data, as well as the ability to perform actions on behalf of the victim. Furthermore, the fact that the vulnerability bypasses the Content Security Policy (CSP) makes it more dangerous, as CSP is an important security mechanism used to prevent cross-site scripting attacks. By bypassing CSP, attackers can circumvent the security measures put in place by the web application and execute their malicious code. This issue has been patched in versions 22.05.13, 21.11.9, and 6.4.27. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.4.2721.06.2 ≤ v < 21.11.922.05.0 ≤ v < 22.05.13
Affected range stops below 21.11.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.05.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.27, so it looks safe — our inference, not a vendor statement
v < 21.11.9v < 22.05.13v < 6.4.27
Affected range stops below 21.11.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.05.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.27, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card