CVE-2023-31144

Craft CMS vulnerable to cross site scripting in RSS feed widget

MEDIUM
6.1
CVSS Score
Published: May 9, 2023 at 03:22 PM UTC
Updated: June 17, 2026 at 05:56 AM UTC
1 product affected across 1 vendorCraftcms

Using cms by craftcms?

Get instant alerts when new vulnerabilities affect cms - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Craft CMS is a content management system. Starting in version 3.0.0 and prior to versions 3.8.4 and 4.4.4, a malformed title in the feed widget can deliver a cross-site scripting payload. This issue is fixed in version 3.8.4 and 4.4.4.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.8.4v < 4.4.43.0.0 ≤ v ≤ 3.8.34.0.0 ≤ v ≤ 4.4.3
Affected range stops below 3.8.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.1MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card