CVE-2023-3085

X-WRT luci 404 Error Template dispatcher.uc run_action cross site scripting

MEDIUM
6.1
CVSS Score
Published: June 3, 2023 at 10:31 AM UTC
Updated: June 17, 2026 at 06:13 AM UTC
2 products affected across 1 vendorLuciWrt Luci

Using luci by X-WRT?

Get instant alerts when new vulnerabilities affect luci - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.5%

Description

A vulnerability, which was classified as problematic, has been found in X-WRT luci up to 22.10_b202303061504. This issue affects the function run_action of the file modules/luci-base/ucode/dispatcher.uc of the component 404 Error Template Handler. The manipulation of the argument request_path leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 22.10_b202303121313 is able to address this issue. The patch is named 24d7da2416b9ab246825c33c213fe939a89b369c. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230663.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 22.10_b202303121313
Affected range stops below 22.10_b202303121313, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (4)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card